Поиск и замена ссылок для УФ

Администрирование - Сервисные утилиты

75
Обработка была создана как аналог обработки под 1С 81 в реализации под 1С 82 на управляемых формах, но также актуальна и для более старших версий платформы.

2009 год:

Аналог обработки под 1С 81 в реализации под 1С 82 УФ.

В плане функционала обработка ничем не отличается от аналогичной под 81, особенности только в реализации.

2017 год:

Обработка актуальна для более старших версий платформы.

2018 год:

Исправлена ошибка "Ошибка формата объекта настроек"

 

75

Скачать файлы

Наименование Файл Версия Размер
ПоискИЗаменаЗначений.epf
.epf 13,83Kb
25.05.18
1512
.epf 1.2 13,83Kb 1512 Скачать

См. также

Комментарии
Сортировка: Древо
1. batys 30.12.09 13:50 Сейчас в теме
Беру, спасибо +
Еще бы групповую обработку как в 8.1 или такая уже есть?
2. waltar 63 01.01.10 18:35 Сейчас в теме
А конвертировать стандартную обработку в 1Сv8.2 не судьба?
3. Душелов 01.01.10 20:22 Сейчас в теме
(2) Понятие "управляемые формы" Вам о чем-то говорит?
darkmessiahan; +1 Ответить
4. lizaniashvily 02.01.10 10:01 Сейчас в теме
Спосибо.

_________________
Stungun электрошокер в Москве.
5. NtS 29.03.10 21:11 Сейчас в теме
в УНФ делаю замену одной валюты на другую, ошибка:
{Форма.Форма.Форма(177)}: Ошибка при вызове метода контекста (Найти): Неверное имя колонки
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя);
по причине:
Неверное имя колонки
6. Паланик 8 07.10.10 14:03 Сейчас в теме
Я щас поглядел, нашел причину, там имя колонки в ТЗ "ВалютаДт", а он ищет по "Валюта", почему так - рыть не стал, тупо поставил счетчик, на какой итерации нестыковка и воткнул условие, где добавляю "Дт" к имени колонки. (извратился, зато за 5 сек)
7. Hoppius 18.01.11 13:30 Сейчас в теме
Извините, но у меня эта обработка в режиме "1С:Предприятие" не открывается совсем%) и никаких ошибок не выдает..
Solo1; Chifa; +2 Ответить
8. CyberCerber 213 18.03.11 15:17 Сейчас в теме
Спасибо за обработку! Только она не заменяет сотрудников как исполнителей задач. Надо еще пробегаться по реквизитам адресации:

                  Если Метаданные.Задачи.Содержит(СтрокаТаблицы.Метаданные) Тогда
				Для Каждого Реквизит Из СтрокаТаблицы.Метаданные.РеквизитыАдресации Цикл
					Если Реквизит.Тип.СодержитТип(ТипЗнч(Ссылка)) И Параметры.Объект[Реквизит.Имя] = Ссылка Тогда
						Параметры.Объект[Реквизит.Имя] = ПравильныйЭлемент;
					КонецЕсли;
				КонецЦикла;
			КонецЕсли;
12. kravchuk 135 23.09.11 07:50 Сейчас в теме
9. diaz 05.09.11 10:34 Сейчас в теме
Не открывается и никаких ошибок не выдает..
kravchuk; +1 Ответить
13. kravchuk 135 23.09.11 07:53 Сейчас в теме
(9) diaz, Видимо вы пытаетесь открыть обработку в режиме обычного приложения, а так как обработка не содержит обычных форм она и не открывается. Попробуйте ее открыть в режиме управляемого приложения.
10. habum 22.09.11 17:07 Сейчас в теме
Спасибо за обработку. Часто пользуюсь, выручает конкретно.
11. DioSka 22.09.11 18:52 Сейчас в теме
Спасибо, очень пригодилось!
14. mlashko 10.01.12 12:59 Сейчас в теме
Гораздо удобнее стандартного средства.
15. fin7 15.01.12 10:32 Сейчас в теме
Спасибо за обработку. Пользовалась не раз. Ошибок не выдает
16. itit 20.01.12 15:04 Сейчас в теме
17. itit 20.01.12 15:49 Сейчас в теме
в зиуп даже неоткрывается
18. Гость 20.02.12 10:28
Спасибо за обработку, пригодилась
19. flack 12 21.02.12 17:44 Сейчас в теме
Хорошая обработка. Спасибо!
itit, в ЗУПе и не откроется, т.к. она для Управляемого приложения.
А для ЗУПа подойдет и стандартная с диска ИТС.
21. Murom 20.03.12 12:16 Сейчас в теме
Очень помогла обработка в УТ 11.
Какие-то умники вели сначала учет на 2ух складах, потом решили вести на 1ом. Столько ошибок понаделали...
Обработкой за 1 мин все подправил.
PS: Вот почему 1с не сделала все универсальные обработки под управляемые формы...
22. tanya_charm 21.03.12 11:32 Сейчас в теме
спасибо за обработку, помогла в переносе для бгу
23. tormozit 4786 26.11.12 11:27 Сейчас в теме
В инструментах разработчика есть мощный инструмент для решения тех же задач "Поиск дублей и замена ссылок".
24. Vanchez 198 18.07.13 13:31 Сейчас в теме
Лично у меня не открывается в БП 3.0, но открывается в УТ 11. Платформа 8.2.16.368
25. Open-BS 19.07.13 14:58 Сейчас в теме
А как посмотреть ссылки на номенклатуру? В УТ 11 что эта обработка, что стандартная, не дает выбрать справочник "номекнлатура"
28. kravchuk 135 28.10.15 13:57 Сейчас в теме
(25) Open-BS,
У справочника номенклатуры может быть представление "Позиция номенклатуры".
27. Solo1 16.10.15 15:18 Сейчас в теме
Не открывается и ошибок не выдает!!!
29. kravchuk 135 28.10.15 13:58 Сейчас в теме
(27) Solo1,

Скорей всего вы пытаетесь открыть ее в режиме обычного приложения.
30. darkmessiahan 20 24.03.17 14:28 Сейчас в теме
ИМХО. Автору стоило бы убрать надпись "8.2", на платформе 8.2 разрабатывали обычные формы. Лучше поставить "8.3 УФ"
31. kravchuk 135 06.05.17 12:41 Сейчас в теме
(30) Для справки: под 8.2 beta появился режим управляемого приложения. в 2009 году сложно было найти инструменты под управляемые формы в связи с чем и появилась эта публикация.

Спасибо за совет.
32. rkandel62 23 07.02.18 16:00 Сейчас в теме
Выдает ошибку - Ошибка формата объекта настроек. Далее - Таблица найденных ссылок отсутствует.
33. kravchuk 135 25.05.18 18:05 Сейчас в теме
(32) Роза, Спасибо. Исправлено.
Оставьте свое сообщение