Загружаем картинки товаров в Битрикс24 через REST API

Обмен - Обмен с другими системами

Пример обработки для загрузки и выгрузки картинки товара из Битрикс24 через REST API.

В продолжении к статье решил разобраться с загрузкой изображений товара в Битрикс24. Были вопросы на эту тему в обсуждении да и сам решил не ждать, пока срочно не понадобится. Так-как по опыту уже знаю, что документации минимум и не все сразу понятно.

И так. Есть товар товар, необходимо загрузить детальную картинку.

В обработке задаю параметры подключения. Где взять client_id, client_secret описано здесь

Параметры подключения

Жмем "Загрузить картинку из файла", выбираем картинку для загрузки.  Необходимо указать ИД товара (смотрим его на форме)

ID товара

ID товара в Битрикс24

ID товара в Битрикс24

 

После чего жмем "Отправить картинку в битрикс". И смотрим результат.

Результат

 

Теперь немного кода. Как передавать картинку нашел в инструкции. Для файла будет сформирована очень длинная строка, которую через метод GET уже не передать. Используем POST.

Функция ОтправитьКартинкуТовара(ИДТовара, Адрес, ИмяФайла) Экспорт
	
	Если ИДТовара = "" Тогда
		Возврат "";
	КонецЕсли;
	
	
	Картинка = ПолучитьИзВременногоХранилища(Адрес);
	СтрокаBase64 = Base64Строка(Картинка.ПолучитьДвоичныеДанные());
	СтрокаBase64 = КодироватьСтроку(СтрокаBase64, СпособКодированияСтроки.КодировкаURL);

	Рез = ОтправитьRESTЗапросPOST("crm.product.update", "id=" + ИДТовара + "&fields[DETAIL_PICTURE][fileData][0]=" + ИмяФайла + "&fields[DETAIL_PICTURE][fileData][1]=" + СтрокаBase64, "");
	
	Возврат "";
	
КонецФункции

И сама функция отправки POST-запроса

Функция ОтправитьRESTЗапросPOST(RESTЗапрос, Параметры, Тело)
	
	ПроверитьТокен();
	
	
	ssl = Новый ЗащищенноеСоединениеOpenSSL(
				//Новый СертификатКлиентаWindows(
				//                СпособВыбораСертификатаWindows.Выбирать),
				Новый СертификатКлиентаWindows(),
                Новый СертификатыУдостоверяющихЦентровWindows());   
                         
	Соединение = Новый HTTPСоединение(
                            АдресБитрикс24,
							, // порт
							, // пользователь
							, // пароль
							, // прокси
                            60, // таймаут в секундах
                            ssl // защищенное HTTPS соединение
                        );
						
	Заголовки = Новый Соответствие;
	Заголовки.Вставить("Cookie", Cookie);

	Запрос = Новый HTTPЗапрос("rest/" + RESTЗапрос, Заголовки);											
	
	Если Параметры = "" Тогда
		ТелоСтрока = "auth=" + AccessToken;		
	Иначе
		ТелоСтрока = "auth=" + AccessToken + "&" + Параметры;
	КонецЕсли;
	
	Запрос.УстановитьТелоИзСтроки(ТелоСтрока, КодировкаТекста.UTF8, ИспользованиеByteOrderMark.НеИспользовать);
			
	Ответ = Соединение.ОтправитьДляОбработки(Запрос);

	РезСтр = Ответ.ПолучитьТелоКакСтроку();
	
	Чтение = Новый ЧтениеJSON;
	Чтение.УстановитьСтроку(РезСтр);
	
	Отв = ПрочитатьJSON(Чтение);

	Возврат Отв;
	
КонецФункции

 

Как подключиться к Битрикс24 и получить токен все описано в предыдущей статье.

Бонусом в обработку добавил пример, как скачать  картинку товара из Битрикс24. Тут намного попроще. В описании товара возвращается ссылка на картинку. По этой ссылке качаем файл изображения.

Функция ПолучитьКартинкуТовара(ИДТовара) Экспорт
	
	Рез = ОтправитьRESTЗапрос("crm.product.get", "id=1", ""); 
	
	Если Рез.Свойство("result") И Рез.result.Свойство("DETAIL_PICTURE") И Рез.result.DETAIL_PICTURE.Свойство("downloadUrl") Тогда
		
		ИмяВремФайла = ПолучитьИмяВременногоФайла();
		
		
		КопироватьФайл("https://" + АдресБитрикс24 + Рез.result.DETAIL_PICTURE.downloadUrl, ИмяВремФайла);
			
			
		Попытка
			
			Картинка = Новый Картинка(ИмяВремФайла);
			
		Исключение
		
		КонецПопытки;
		
		УдалитьФайлы(ИмяВремФайла);
		
		Возврат Картинка;
		
	Иначе
		
		Возврат Неопределено;
		
	КонецЕсли;
	
	
	
КонецФункции

 

Обработка тестировалась в УНФ 1.6.10.50. Должна работать в любой конфигурации, созданной под УФ на 8.3.

Скачать файлы

Наименование Файл Версия Размер
Загружаем картинки товаров в Битрикс24 через REST API
.epf 10,51Kb
17.10.17
7
.epf 1 10,51Kb 7 Скачать

См. также

Комментарии
Сортировка: Древо
1. isaev2016 07.11.17 04:24 Сейчас в теме
А можно ли работать с файлами в других сущностях - например - "Коммерческое предложение" или "Счет". Пока нашел в описании только у задач.
2. user662672_explorer2000 114 07.11.17 07:36 Сейчас в теме
Смотрим в документацию, если у задач есть метод task.item.addfile, то у счетов и коммерческих предложений ничего подобного нет. У коммерческого предложения есть товарные позиции, которые в свою очередь могут содержать изображения. Ничего больше, чем дает API не придумать
3. isaev2016 07.11.17 17:45 Сейчас в теме
(2) Списался с техподдержкой. Добавили пользовательское поле с типом файл и туда получилось прикрепить.

"&fields[UF_CRM_1510048875][fileData][0]=" + Формат(Выборка.Номер,"ЧРГ=' '; ЧГ=0")+".pdf" + "&fields[UF_CRM_1510048875][fileData][1]=" + СтрокаBase64
4. user662672_explorer2000 114 07.11.17 18:39 Сейчас в теме
(3) Интересно, спасибо за информацию!
Оставьте свое сообщение