Структура подчиненности в УТ 11.4

Программирование - Практика программирования

Структура подчиненности

11
В 11.4 опять был изменен механизм структуры подчиненности, вот как я его реализовал в 11.4.1.241.

Добрый день, хочу поделиться, вдруг кому-то пригодится.

Итак, в 11.4 опять был изменен механизм вызова отчета "Структура подчиненности", в связи с тем, что в нашей конфигурации есть не типовые документы, которые мы добавляли сами, то вот как у меня получилось реализовать это в УТ 11.4.1.241:

1. Добавляем наш документ в "Критерий отбора", там отмечаем его в "Данные", а так же ДокументОснование в "Состав" (это надо было делать и во всех прежних конфигурациях).

2. В Модуле формы документа следующий код:

   &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
        
    ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
    
    КонецПроцедуры
    
    &НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
    
    ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
    
КонецПроцедуры

3. В модуле менеджера документа:

Процедура ДобавитьКомандыОтчетов(КомандыОтчетов, Параметры) Экспорт
    
ВариантыОтчетовУТПереопределяемый.ДобавитьКомандуСтруктураПодчиненности(КомандыОтчетов);
    
КонецПроцедуры

4. в Общем модуле "ВариантыОтчетовПереопределяемый" в процедуре "ОпределитьОбъектыСКомандамиОтчетов(Объекты)" необходимо добавить ваш документ такой строкой:

Объекты.Добавить(Метаданные.Документы.ВашНовыйДокумент);

Вот, собственно, и все. Если есть какие-либо комментарии и дополнения, то пожалуйста.

11

См. также

Комментарии
Избранное Подписка Сортировка: Древо
1. Трактор 1164 29.11.17 09:15 Сейчас в теме
Шо? Опять?! Злодеи. Мне тоже придётся переделывать. Я, кстати, добавил в структуру подчинённости документы связанные через назначение. Отчёт стал информативнее.
2. kolya_tlt 11 29.11.17 09:23 Сейчас в теме
причем тут УТ, обновили его в БСП
oleganatolievich; cleaner_it; +2 Ответить
3. wolfsoft 2421 29.11.17 09:44 Сейчас в теме
Плюсанул, но поздно, сам уже до всего дошёл.
4. oleganatolievich 05.02.18 13:41 Сейчас в теме
спасибо большое. недавно обновил УТ до 11.4.
Оставьте свое сообщение